This project has moved and is read-only. For the latest updates, please go here.

Snoop Snoops Snoop (instead of my application)

Jul 19, 2010 at 7:59 PM

I have an app that seems to confuse snoop when it tries to attach.  I select my app from the drop down and click the "Snoop this Application" button, but instead of it showing stuff about MY app, it gives me stuff about snoop (The tree is just [000] (App) 1, [001] (SnoopUI), and 3 Resources (niceNamer, stylelessTextBlockDataTemplate, and refreshButton).


Any idea whats up w/ that?

Jul 19, 2010 at 8:15 PM

Have you tried using Ctrl-Shift and mousing over the application that you are trying to Snoop? This will refresh the visual tree and hopefully select the item you are trying to Snoop.

Let me know if that doesn't work (or hasn't worked).

Jul 19, 2010 at 8:21 PM

The Ctrl+Shift trick does, indeed, make it do its thing.  Thanks!

Jul 19, 2010 at 8:37 PM
Great to hear! By the way, it is in my plans to make this (Ctrl-Shift) functionality more obvious to the user with a StackOverflow like tip bar.
Jul 19, 2010 at 8:38 PM
Also, love the subject on this issue. Heh heh.
Jul 19, 2010 at 10:01 PM

I figured out what the real issue here.  Our app has a splash screen (started w/ app.xaml's StartupUri) which eventually gets killed off after the real main window is up and doing its thing.  I have a repro project here: .  It seems like setting the Application's MainWindow to the newly created window fixes the problem from my end as well.

Jul 19, 2010 at 10:40 PM
Yes, I actually wondered if you might be doing something with the original main window ... and realized that Snoop Ctrl-Shift mouse functionality might help you out. If you have the freedom to reset the Application's MainWindow ... to the actual main window ... that is a good thing to do (besides making it easier to Snoop).