Snoop opens with height of 1 pixel

Jan 24, 2012 at 7:16 PM

Greetings,

First of all I want to say that Snoop is by far one of the best tools that I have been lucky enough to run across... which is why this problem has been such a pain.  When I open Snoop the application is opening with a height of 1 pixel.  Thus far I have found no way to stretch the window or even grab it and move its screen location.  I have tried uninstalling / re-installing, making sure that the Program Files (x86) folder is deleted, searching my registry for any weird snoop related settings, running as administrator, and even tried to muck with the app.config file to see if I could at least get some sort of reaction... nothing has worked.  The really frustrating thing is that it was working fine and then 'suddenly' started acting weird.  I did update my graphics drivers and my company pushed out a number of MS updates around the time this issue started however I cant say for certain whether or not I ran Snoop after these updates were applied.  I am running Windows 7 64-bit on a laptop with an Nvidia Quadro NVS 135M graphics card, driver version 285.62 (in case that has any relevance). Any help would be greatly appreciated.

Coordinator
Jan 24, 2012 at 7:45 PM

I have run into that problem myself, I think. For me ... it is an intermittent issue ... and occurs only once in a while.

What I do ... is use a utility like Sizer (http://www.brianapps.net/sizer/) to resize the application. Sizer can even be used to move a window that is completely off screen ... to on screen ... by accessing the Sizer menu via a right click on the app in the Task Bar.

I think the problem comes out of how we have implemented the saving of user settings (like window position and size). At some point, I would like to revamp that whole part of Snoop.

Try using Sizer and see if it helps you.

 

More Information

The user settings do get saved in the app.config file ... but Snoop makes the problem a little tricky ... since it injects itself into the Snooped process.

In other words, the position and the size settings for the app chooser (i.e. the thin blue bar that comes up when you execute Snoop) are stored in the Snoop config file ... but the position and the size settings for the main Snoop UI (i.e. the property grid window that comes up when you Snoop an app) ... is actually stored in the config file for the app being Snooped.

One thing that you can try ... if Sizer doesn't work for you ... is to go to your local user settings area and delete the user.config files for both Snoop and the application you are Snooping.

For example, for the released 2.7.0 version of Snoop ... the user.config file is stored at: C:\Users\plottsc\AppData\Local\Cory_Plotts\Snoop.exe_Url_svr3ea1awr4rmikpujw0xmksr1tpt4kp\2.6.1.0

Deleting the above file should revert the position and size information for the app chooser back to its defaults.

And to continue the example, the user.config file for the application I Snoop most often is stored at: C:\Users\plottsc\AppData\Local\Starkey\Starkey.Inspire.Host.Stan_Url_qxzblujf3qlnz4mqhww3tnfs1lvpcdqs\8.0.11.113

I work for a company called Starkey Laboratories ... and the assembly I'm Snooping is Starkey.Inspire.Host.Standalone.exe. Deleting the above user.config file should revert the position and size information for the main Snoop UI (and the other windows) back to their defaults.

 

Hope this helps ... and sorry for the pain this issue is causing.

Let me know if you get around it.

Jan 24, 2012 at 9:49 PM

Wow, I seriously didn't expect a reply so quickly.  I downloaded sizer but wanted to try deleting the user.config file first and that worked like a charm.  Thank you for adding the "More Information" section, that was very helpful and good information to know in case myself or any of my colleagues run into this problem in the future.

Your my hero for the day :)

Coordinator
Jan 24, 2012 at 9:55 PM

Glad to help ... I wanted to document the issue for my own sake ... so that when I go to refactor this bit ... it is all there in a discussion post.

Sizer, btw, is one of the first utilities I install on new machine. I love that little utility!

By the way, I was curious ... what window was showing up small? The app chooser? Or, the main Snoop UI?

Jan 24, 2012 at 10:10 PM

It was the main UI.  Basically when I launched the application, the Snoop icon would show up in the Task Bar and a blue line would show up across the screen.  If I positioned the Mouse just right I could focus the app and see the 'glow' of the minimize and close buttons light up when the mouse passed over them.